Microsoft MVP Logo

Somasgear blogged earlier this week on some Visual Studio supportability with Vista and the availability of VS 2005 SP1 (beta). Why anyone would install the beta of a service pack is beyond me, but to each his own. While this service pack is WAY overdue, it is nice to know that we're only 3-4 months out for a final RTM release. What is crazy though, is the version support decisions Microsoft has made for Visual Studio... get this:

  • Visual Studio 2002 & 2003 - NOT SUPPORTED on Vista
  • Visual Studio 2005 - supported (with SP1)
  • Visual Basic 6.0 - supported

VS 2003 is a legacy product? HELLO! Last I checked, there were TONS of CLR 1.1 apps out there... so all you who are supporting CLR 1.1 apps (such as you WSS v2 & SPS 2003 developers), you can't upgrade your development machine to 2003. Granted, a good workaround would be to install VS2003 within a virtual machine... but come on! Bad decision Microsoft... wouldn't be surprised to see enough pushback to where Redmond cries uncle on this one... just keep screaming bloggers!

» Visual Studio 2005 SP1 Beta and Visual Studio support for Vista

Comments powered by Disqus